× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Valve stem oil seals

More
07 Aug 2020 21:10 #226283 by Valleymills
Replied by Valleymills on topic Valve stem oil seals
Havent noticed any but will check

Please Log in or Create an account to join the conversation.

More
07 Aug 2020 21:29 #226285 by Roger Fairclough
I don't know the specific details of your engine but it is normal for the designer to incorporate traps so that on initial start up there is enough oil to lubricate, in your case, the valve stems. It can take up to 30 seconds for the oil to circulate throughout the engine and the cam box is last to get it. It is quite possible that the seals are slightly worn and on initial start up a small amount of oil has got past the seal lip and it is that that gets burnt. If the amount that the engine burns is acceptable to you, say a pint in 1000 miles, then I would leave well alone.

Roger

Please Log in or Create an account to join the conversation.

More
07 Aug 2020 21:31 #226286 by Valleymills
Replied by Valleymills on topic Valve stem oil seals
Thanks

Please Log in or Create an account to join the conversation.

More
07 Aug 2020 21:50 #226287 by helijohn
Replied by helijohn on topic Valve stem oil seals
If the Jimny is a keeper then I'd get it done.

Do it right - use Hammerite
When the blue light is flashing I am kidding.

Please Log in or Create an account to join the conversation.

Time to create page: 0.080 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.

We use cookies to give you the best online experience. Please let us know if you agree to all of these cookies. Accepting the Cookies also accepts the Disclaimers for the website.