× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Wobble at 80-85km/h

More
21 Jul 2022 19:41 #244184 by Score
Wobble at 80-85km/h was created by Score
Hello everyone 

This is my first post here and i hope you can help me with my problem.

I own suzuki jimny 2018 1.3 MT black raptor lift kit  225/r15 tyres .
Am suffering from a wobble at 80-85 km/hr even after i put the shims i still have the wobble sometimes i feel like its going to catch the death wobble .

I lift the car from the ground and checked the king pin bearing for both front tyres and it seems good they are not wobbling with and without braking .

any help or advice ?
 

Please Log in or Create an account to join the conversation.

  • Lambert
  • Lambert's Avatar
  • Offline
  • Moderator
  • Moderator
    Registered
  • The quickest Jimny in Harrogate...(that I own)
More
21 Jul 2022 20:07 #244186 by Lambert
Replied by Lambert on topic Wobble at 80-85km/h
Welcome to the forum. The lift kit that you have is how tall and does it have any form of castor correction? Also does it have a steering damper fitted? The thing is that once you start fitting bigger tyres and taller suspension the tendency of the suspension/steering as a whole system is to become increasingly prone to wobble even if everything is in good condition.

Temeraire (2018 quasar grey automatic)
One of the last 200ish of the gen3s, probably.

Please Log in or Create an account to join the conversation.

More
22 Jul 2022 10:39 #244193 by Score
Replied by Score on topic Wobble at 80-85km/h
Hi lambet.
There is no castor correction and am not sure if it 2 or 3 inch kit.

I installed the stock shocks and coil springs and the problem remain the same .
I made 2 times wheel balance and alignment the wobble will decrease but will not go but later it will come back the same wobble .

Now it need also alignment after replacing the new axle tube because i already bent the the old axle tube so far :( .

When i steer to left it not turn full 2 turns and for the right it turn 2 and alittle more .

When i see the car from the out side i feel like the left tyre is a little bent to insinde from the upper part but for the right tyre its standing straight no bent to inside.


I know its a complicated problem but am trying hard to figure out what cause these problems and am looking for your help and advice .

Please Log in or Create an account to join the conversation.

Time to create page: 0.113 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.

We use cookies to give you the best online experience. Please let us know if you agree to all of these cookies. Accepting the Cookies also accepts the Disclaimers for the website.