× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

HELP! :( The Jimny Boogie won't start... diagnostic video

More
13 Apr 2021 16:14 - 13 Apr 2021 16:16 #234445 by RainerK
Maybe this is an indication to check and clean the electrical connections. This usually does not take too long and might help a lot, especially if you plan to drive through water.

I would disconnect each plug, clean with a wire brush if possible, blow out with air, use some contact spray, again blow out with air and re-plug.

If the connections look corroded, then I dip-clean them with alloy cleaner, thoroughly rinse, blow out with air, use some contact spray reconnect and then use fluid Film Max as corrosion protection and the same for all ground connections. Some people do not approve the use of a fat based corrosion protection for electrical connections because it might increase the resistance. So far I did not have any issues with it reliably prevents corrossion.
Last edit: 13 Apr 2021 16:16 by RainerK.
The following user(s) said Thank You: X8GGY

Please Log in or Create an account to join the conversation.

  • X8GGY
  • X8GGY's Avatar Topic Author
  • Offline
  • Platinum Member
  • Platinum Member
    Registered
  • but currently AWOL
More
13 Apr 2021 16:40 - 13 Apr 2021 20:45 #234447 by X8GGY
I might have spoken too soon? :lol:

 

More details later, quick change and back to work :(
 
Attachments:
Last edit: 13 Apr 2021 20:45 by X8GGY.

Please Log in or Create an account to join the conversation.

More
13 Apr 2021 17:46 #234452 by Scimike
Damn, hope it's something simple.

Yokohama Geolanders, Sony 2D head unit, Elvis Bobblehead, Jimnybits transfer Guard, Hand crafted Indian hanging Elephant, Koni Heavy track dampers, Voodoo Doll with pins (active spell - I believe it's working), Jimnybits Adventure Rack, towbar, Light bar and vintage caravan.
The following user(s) said Thank You: X8GGY

Please Log in or Create an account to join the conversation.

  • X8GGY
  • X8GGY's Avatar Topic Author
  • Offline
  • Platinum Member
  • Platinum Member
    Registered
  • but currently AWOL
More
13 Apr 2021 21:29 #234455 by X8GGY
The following user(s) said Thank You: Soeley

Please Log in or Create an account to join the conversation.

  • X8GGY
  • X8GGY's Avatar Topic Author
  • Offline
  • Platinum Member
  • Platinum Member
    Registered
  • but currently AWOL
More
18 Apr 2021 17:02 - 18 Apr 2021 17:07 #234549 by X8GGY
SUCCESS today!

Started the day under The Boogie with a piece of sandpaper and some pliers... took the spade connector off the starter motor's solenoid, cleaned the male blade connector on the solenoid with the sandpaper, and gave the female side of the spade connector on the end of the wire a couple of squuezes with the pliers until it refitted snuggly onto the blade and would make a better connection...

Started it, stopped it, started it... repeated a good few times, happy with that... so then I rechecked all the jubilee hose clips and found one slightly loose which had caused the loss of coolant water  on the last shakedown trip...



I then filled the radiator / system back up with water and left The Boogie running on the drive whilst I made a cup of tea, went back out to find it up to temperature with no leaks... so I finished my tea...

And then drove it round the block, over all the speed ramps...

Back into the drive, turned it off, restarted it, repeat, repeat...

Happy with that, I went for a longer test run, and then... back to the drive, check the cooling system, all good, stopped, started, repeat, repeat...

Then I thought I'd go drive some greenlanes...

Ummm, then I thought better of that, and decided to drive to my Mum's just in case! ;) Had a cup of tea there and a good catchup chat, and Mum said my long lost brother was due to come round too, so I waited for them and had more tea and some cake in the garden...

Back out to The Boogie, and VROOM, started first time, and then flew back along the North Wales Expressway...

Feeling brave now, so I'll probably venture out onto a few greenlanes next Sunday... ;)

Sorted! :woohoo:
Last edit: 18 Apr 2021 17:07 by X8GGY.
The following user(s) said Thank You: Soeley

Please Log in or Create an account to join the conversation.

More
18 Apr 2021 17:25 #234552 by Mike G
Excellent.  Hopefully you'll get good use of the nice weather now.  

2" Trailmaster suspension lift, 2"body lift, snorkel, full breather kit, 29" steel wheels with BFG tyres, tinted rear windows, CRT CB radio with modulator antenna mounted on rear, dog cage and tray in the back.
The following user(s) said Thank You: X8GGY

Please Log in or Create an account to join the conversation.

  • X8GGY
  • X8GGY's Avatar Topic Author
  • Offline
  • Platinum Member
  • Platinum Member
    Registered
  • but currently AWOL
More
18 Apr 2021 17:33 #234553 by X8GGY
Indeed Mike ;)

ready just in time for the summer... and it's supposed to be a good one this year? B) 

Please Log in or Create an account to join the conversation.

More
18 Apr 2021 17:44 #234554 by Mike G
I like the optimism.  Let's hope so. 

2" Trailmaster suspension lift, 2"body lift, snorkel, full breather kit, 29" steel wheels with BFG tyres, tinted rear windows, CRT CB radio with modulator antenna mounted on rear, dog cage and tray in the back.

Please Log in or Create an account to join the conversation.

Time to create page: 0.108 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.

We use cookies to give you the best online experience. Please let us know if you agree to all of these cookies. Accepting the Cookies also accepts the Disclaimers for the website.