×
Search (23 Feb 2018)

A trial enhanced search facility has been enabled. Please use the Google Custom Search above.

× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Idling issue

More
11 Jan 2018 15:04 #188284 by Margin
Idling issue was created by Margin
Hi
I have a 2004 Jimny Mode. Recently it has started to drop the revs suddenly (on idling) and almost stalls but then picks up again.
Any ideas what the problem might be?

Many thanks

Please Log in or Create an account to join the conversation.

More
11 Jan 2018 17:02 #188286 by Lambert
Replied by Lambert on topic Idling issue
Is it producing any fault codes?

It's not a Jimny. It's my Jimny

Mooo said Ermintrude (black)
Boing said Zebedee (blue)

Please Log in or Create an account to join the conversation.

More
12 Jan 2018 02:51 #188297 by CharlesS
Replied by CharlesS on topic Idling issue
Most vehicles with EFI have some sort of Idle Air Controller (solenoid) that controls the amount of air bypassing around the throttle plates to maintain a steady idle. When idle reacts slowly either the bypass air port or idle air solenoid could be dirty. Both should be cleaned with throttle body cleaner. Generally the Idle Air Solenoid it attached to the throttle body, I have service numerous on Jeeps, but not familiar where the Idle Solenoid is located on the Jimny, I am sure someone can provide its location along with a description of what it looks like.
The following user(s) said Thank You: Margin

Please Log in or Create an account to join the conversation.

More
25 Jan 2018 12:01 #188834 by Margin
Replied by Margin on topic Idling issue
Hi

No it isn't

Please Log in or Create an account to join the conversation.

More
25 Jan 2018 12:24 #188836 by furo
Replied by furo on topic Idling issue
I also have a 2004 Mode and I'm having a similar problem, so I'm interested to follow this. Do your revs go high initially or just low? When I start mine cold it revs up to 2000 revs, then wavers between 1000 and 2000 for around 30 sec then drops to normal. Then it occasionally drops below 500 and judders. Generally after driving for a few minutes there are no issues. Is that similar to yours?

I've tried to take off the IACV to clean it but the nut was rounded off.

2004 Jimny Mode; General Grabber AT3s (215/75/R15); Trailmaster 2" Lift; Jimnybits Snorkel; Jimnybits Front and Rear Recovery Points; Osram Nightbreakers; Suntop Roof Rack; AVM Manual Hubs; ORA Radius Arm Guards; Stainless Steel Exhaust System.

Please Log in or Create an account to join the conversation.

  • Busta
  • Busta's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Norfolk's official off-roading God.
More
25 Jan 2018 17:11 #188839 by Busta
Replied by Busta on topic Idling issue
Every Jimny I've had does this occasionally. They never stall, and it's never caused any issues so I just ignore it. Cleaning the ICV would be the obvious thing.

Please Log in or Create an account to join the conversation.

Moderators: funkyjimnyooky_123
Time to create page: 0.068 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.