×
BigJimny Meet - 2020 (01 Nov 2019)


Its the big one! The 50th Anniversary of the Jimny.

17th May 2020

Parkwood (Tong - near Leeds)

£35

BOOKING OPEN - CLICK HERE TO BOOK

Event details are HERE

× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Temporary/timed warning lights on dashboard

More
01 Apr 2019 15:50 #205366 by Keirravn
Hey all.

In the process of fault finding behind the dash I've managed to knock out some of my warning lights. I believe I shorted them out. Engine management and oil are the obvious ones that aren't working. It's not the bulbs. Battery light and abs light still works.

Is there a relay somewhere that controls the lights that come on for a few seconds? Is it built in to the circuitry of the instrument panel?

Help appreciated :)

Please Log in or Create an account to join the conversation.

  • Riccy
  • Riccy's Avatar
  • Online
  • Site Sponsor
  • Site Sponsor
    Registered
  • J999 MNY Bashing around Carlisle
More
01 Apr 2019 15:59 #205367 by Riccy
Checked all the fuses? some under the dash and some near the battery

J999 MNY, ULYSSES M18 VVT
Pickup/tipper, R7me gbox & 4.3 Rocklobster, 31" Toyo MT, 2x ARB Locker diffs, 4" lift, Recaro's, Caged, etc

www.youtube.com/user/riclemus

Please Log in or Create an account to join the conversation.

More
01 Apr 2019 16:05 #205370 by Keirravn

Riccy wrote: Checked all the fuses? some under the dash and some near the battery

Dash fuses fine. Wouldn't have thought the fuses by the batter would impact it but I'll check to be sure

Please Log in or Create an account to join the conversation.

More
01 Apr 2019 16:53 #205373 by Keirravn
Nope no underbonnet fuses relate to this

Please Log in or Create an account to join the conversation.

  • Riccy
  • Riccy's Avatar
  • Online
  • Site Sponsor
  • Site Sponsor
    Registered
  • J999 MNY Bashing around Carlisle
More
01 Apr 2019 18:02 #205374 by Riccy
sorry for the obvious question, but it had to be asked. Check earthing and connections, otherwise its a spare part needed.

J999pre will probably have a spare dash cluster to swap in. Mileage displayed will correspond to the used part there, but it should work.

J999 MNY, ULYSSES M18 VVT
Pickup/tipper, R7me gbox & 4.3 Rocklobster, 31" Toyo MT, 2x ARB Locker diffs, 4" lift, Recaro's, Caged, etc

www.youtube.com/user/riclemus
The following user(s) said Thank You: Keirravn

Please Log in or Create an account to join the conversation.

More
01 Apr 2019 18:08 #205376 by Keirravn

Riccy wrote: sorry for the obvious question, but it had to be asked. Check earthing and connections, otherwise its a spare part needed.

J999pre will probably have a spare dash cluster to swap in. Mileage displayed will correspond to the used part there, but it should work.

So do you reckon the instrument panel has internal resistors or some such which controls the temporary light up as opposed to it being a separate part or from the ECU?

Please Log in or Create an account to join the conversation.

  • Riccy
  • Riccy's Avatar
  • Online
  • Site Sponsor
  • Site Sponsor
    Registered
  • J999 MNY Bashing around Carlisle
More
01 Apr 2019 18:12 #205378 by Riccy
Yes it has a PCB sort of arrangement and has IC's and processors, so easily damaged part. Like i say, the mileage is stored in the dash cluster somehow, therefore it must be more than just lights and wires to them. I doubt the ECU would be damaged or the car would have bigger issues.

have you had a code reader on to see if that works?

J999 MNY, ULYSSES M18 VVT
Pickup/tipper, R7me gbox & 4.3 Rocklobster, 31" Toyo MT, 2x ARB Locker diffs, 4" lift, Recaro's, Caged, etc

www.youtube.com/user/riclemus
The following user(s) said Thank You: Keirravn

Please Log in or Create an account to join the conversation.

More
01 Apr 2019 18:35 - 02 Apr 2019 18:23 #205381 by Keirravn

Riccy wrote: Yes it has a PCB sort of arrangement and has IC's and processors, so easily damaged part. Like i say, the mileage is stored in the dash cluster somehow, therefore it must be more than just lights and wires to them. I doubt the ECU would be damaged or the car would have bigger issues.

have you had a code reader on to see if that works?

Ah great that would be a handy easy fix then. Just a shame to lose my 66k on the clock :P

I do but there's no faults showing. MOT is out I was planning to put it in to the garage tomorrow. Typical really
Last edit: 02 Apr 2019 18:23 by Keirravn.

Please Log in or Create an account to join the conversation.

More
03 Apr 2019 05:47 #205449 by kirkynut
Start by replacing the bulbs. These lights are controlled by the ecu as to when they go out. There's unlikely to be a fault with that, so you've damaged something where they plug in, either the bulbs themselves or the holders.

I'm not sure but the ecu might store the mileage. So a replacement might show your car's mileage.

Kirkynut

The underdog often starts the fight, and occasionally the upper dog deserves to win - Edgar Watson Howe.

My Jimny Thread Here: www.bigjimny.com/index.php/forum/8-my-ji...on-continues?start=0
The following user(s) said Thank You: Keirravn

Please Log in or Create an account to join the conversation.

More
03 Apr 2019 07:55 - 03 Apr 2019 07:57 #205450 by yakuza

kirkynut wrote: I'm not sure but the ecu might store the mileage. So a replacement might show your car's mileage.

Kirkynut


Nope, my mileage (km) was very much improved after changing the cluster.
Pictures: www.bigjimny.com/index.php/forum/8-my-ji...kuza?start=84#203590
might be different on older cars though, mine is a 2005. the cluster is 2012.
Could be there is also a milage read out from the ECU that shows the real mileage, but that does not update the cluster mileage.

Brake warning light did not shut down before, and after changing the cluster more lights will shine for a test first few seconds after turning ignition on. Can hear relays clicking on - off corresponding to the warning lights as well now.

2005 Jimny M16A VVT, 235 BFG MT, 2" Trailmaster, 17%/87% high/low gears.
Last edit: 03 Apr 2019 07:57 by yakuza. Reason: add info
The following user(s) said Thank You: Keirravn

Please Log in or Create an account to join the conversation.

More
03 Apr 2019 10:12 #205457 by Keirravn
The bulbs are ok. It's possible I've burned the circuitry in the green plastic on the back of the cluster. I think trying a new cluster is the easiest way. Shame I don't have a friend with one I could borrow but I guess if I buy one and it doesn't cure it I can try to sell it on.

I can live without a management light but the oil light is also missing which is the potentially worrying and expensive issue ...

Please Log in or Create an account to join the conversation.

More
03 Apr 2019 10:54 #205463 by yakuza
I measured the signals on the connectors into the cluster to find they were all there and correct before buying a new one..
It is all there in the FSM, but the wiring inside the cluster is more difficult to find.

2005 Jimny M16A VVT, 235 BFG MT, 2" Trailmaster, 17%/87% high/low gears.

Please Log in or Create an account to join the conversation.

Time to create page: 0.204 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.